3 Replies Latest reply on Nov 22, 2016 3:49 PM by yredovich

    Polycom 601 config file error

    numkeeen New Member

      I have recently tried resetting my polycom ip 601 from phone interface, it started out well and downloaded all the files but at the end while processing configuration it comes up with an error 'config file error, 'error is 0x4020'. And now it is on a loop of restarting the phone after displaying config error.

        • Re: Polycom 601 config file error
          patrick Employee

          I hope you also opened a discussion with Polycom, but with a quick search I was able to find this article that says the 0x4020 error could be a missing or bad file on the provisioning server. I found another article that states that it could be the time server.


          Good luck,


            • Re: Polycom 601 config file error
              numkeeen New Member

              you are right this could be a bad file on the provisioning server. But i want to know what should i do to make it right. Because it was a used phone and i tried to reset factory settings so phone started to download new files from provisioning server but at the end it comes with this error.


              Thanks for your response.

            • Re: Polycom 601 config file error
              yredovich New Member

              I would check the 000000000000.cfg file or the macaddress.cfg (i.e. 0004f1234567.cfg) files on the provisioning server. It should contain exact names of firmware and config files that the phone will use to provision, i.e.


              <APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="user.cfg, polycom601.cfg, sip.cfg" MISC_FILES="">


              In this example, the firmware is called simply sip.ld, while config files "user.cfg", "polycom601.cfg" and "sip.cfg" will give the phone the rest of the provisioning details. All of these files must exist on your provisioning server. Double check the spelling and contents of these files, especially if you don't have any other Polycom or Polycom 601 phones that are working already.


              I would also review access logs from your provisioning server, covering the phone booting interval. It will provide clues as to which files the phone has trouble accessing.


              Since it's a used phone, if you want a quick way to find out if the phone is in working condition, you can download the bootROM and SIP firmware directly from Polycom. The last SIP load that supported this model is 3.1.8, while the last bootROM is 4.1.3. Download and extract all files (which will come with their own set of example config files) to a temp directory. Get a free TFTP server (I use TFTPD32) and point it to the same temp directory. Go into phone's setup, tell it to use TFTP and enter the IP address of your computer. After a few reboots the phone should come up on the bootROM and SIP firmware you downloaded. It should have dial tone, but won't be associated with any account, so it won't be able to make/receieve calls.


              At that point, you could re-point the phone back to your provisioning server, but if you get the same error back, then the most likely reason is misconfiguration on the prov server you're using.