0 Replies Latest reply on Aug 3, 2015 12:16 PM by blamethenetwork

    SCP firmware upgrade on NetVanta 1638P?

    blamethenetwork New Member

      I like to update the switch firmware on all my other switches by using SCP from the switch to pull down the firmware image to the switch storage, and then executing whatever platform-specific commands are needed to update and reboot.


      I've tried doing this on the Adtran NetVanta 1638P, but when I run

      copy scp user@ flash NV1638A-R11-7-0.biz


      I am prompted for my password, I enter it, and it sits like this forever:

      SW-VOICE-5A#$/home/user/NV1638A-R11-7-0.biz flash NV1638A-R11-7-0.biz
      Initiating SCP transfer...


      I'm trying to copy the firmware image from a CentOS 7 server with a stock sshd_config file.


      Here's the output of the dir command (commas added to numbers for readability), which shows that I have plenty of free space on the device (I think). According to 'ls' on my workstation, the firmware image is only 21,770,532 bytes.

             15503652 9700568-2R100501.biz
             21104932 NV1638A-R11-3-0.biz
                13653 startup-config
                11609 startup-config.bak
                  787 STCFG568.TXT
      44,541,952 bytes used, 89,675,776 available, 134,217,728 total


      The device in question is running R11.3.0, and I am using the eth 0/1 out-of-band management port. ICMP reachability between the switch's control plane and the server hosting the firmware version has been verified.