2 Replies Latest reply on Feb 25, 2014 5:04 AM by xucraig

    Force DynDNS Update

    xucraig New Member

      Hello everyone,


      Here's a thread from a while back describing our setup for reference: Dynamic-DNS Behavior


      I've noticed that a number of my sites have recently stopped updating properly. This may be an issue with the DynDNS.com, but since their logging is lacking, I figured I'd start here. 


      I have a number of different routers running different firmwares (from 18.0.2 -> R10.9.1) all experiencing the same issue.  Some update fine, while others do not.


      When I run sh dynamic-dns, I'll receive Is Updated: no on all the routers that don't update.  When I try to debug dynamic-dns, I'm not getting any output.  I've tried shutting down the interface and bringing it back up, along with going in and removing the dynamic-dns statement from the interface and re-adding it.  Sometimes I can get it to update by rebooting, but I'd prefer not to do that, especially since that isn't 100% consistent.


      Is there any way to force an update from the cli? 


      Does anyone know of any changes to DynDNS recently that would cause inconsistent operation with Adtran specifically?


      thanks in advance for any assistance.  if you need any more info, let me know.



        • Re: Force DynDNS Update



          Thank you for asking this question in the support community.  At the time of this post, there is not a command to force a DynDNS update in the CLI of the ADTRAN.  The debug dynamic-dns <verbose> command will display output when the DynDNS process is updating.  If you enable the dynamic-dns debug, and then remove the dynamic-dns configuration from the interface, followed by re-configuring it, the debug will show the process attempting to update and you can troubleshoot the output to see where it is failing.  If you would like to reply with this debug output, I will be happy to review it for you.



            • Re: Force DynDNS Update
              xucraig New Member

              Thanks Levi,


              It ended up being an issue on DynDNS' side.  The account had gotten locked out.  Running debug dynamic-dns verbose on a couple of routers showed us the authentication error.


              They weren't able to tell us why some were updating and others weren't (they all share a single update account), but the issue's fixed.


              I appreciate your help