2 Replies Latest reply on Aug 29, 2013 9:03 AM by daniel.blackmon

    The PostgreSQL server failed to start

    technician New Member

      I have recently been experiencing this error after rebooting the vWLAN appliance to prepare adding additional APs to the system. When I watch the console I'm greeted with this error message:


      The PostgreSQL server failed to start. Please check the log output: [fail]


      I have also seen this error message:


      fatal could not write lock file "postmaster.pid" no space left on device


      This also appears to be related to PostgreSQL. Unfortunately I cannot get to a command line as the system hangs (nor do I get a web interface) and does not recover, even if left overnight.


      If I reboot the server and hit SHIFT just after BIOS init I see two options in GRUB.





      vWlan_1 is the non functioning one. vWlan_2 looks like an older version, which does go to a command prompt. I've also tried going to the command prompt right from GRUB ('c' option), but I am not sure what credentials to use (I tried my admin credentials and the defaults listed in the admin guide).


      I'm guessing the solution is to clean out the filesystem somehow, but I'm not sure how to go about the process. Any input would be appreciated.


      vWLAN version is




      I was able to resolve the issue by going back to an April backup. I would still like to hear from anyone with opinions on logs or something similar taking over hard drive space and causing the PostgreSQL server init to fail. I'm anticipating this issue cropping up again in a month or two.