4 Replies Latest reply on Sep 5, 2013 9:21 AM by nick

    Bluesocket Guest access redirection not working

    leighton New Member


      I have been playbing around with the guest access in the vWLAN which we have installed on a vmware server in our Data Centre. The issue I have is that when I connect to the guest SSID and I open a webpage it seems to be doing the redirect but it appears to be re-directing to the private IP address of the vWLAN server instead of the WAN IP address. See below URL of the redirection when I tried kb.adtran.com in Google chrome, Seems like chrome shows this up better than IE as it just times out and gives a 404 not found in IE, But chrome shows the url that it is redirecting to.



      I checked the online docs and checked that it was doing a DNS lookup and when I do an ipconfig I can see that I have gotten the DNS address ( for testing) and I can ping google.com and it gets resolved although I dont get a response. I also enabled https redirect in the configuration - System - Setting tab but it has not made any difference.


      Is there something that I am missing.I also have the public address in the "Public IP address for vWLAN standalone or high availability master" and have the following ports forwarded to the vWLAN controller.

      port 69

      port 33334

      port 33333

      port 28000

      port 2335

      port 3000

      port 1812

      port 53


      Everything is working fine in terms of the standard wifi access for all users but this guest access is something that I would like to demo but for the life of me I cant see why its not working.


      Any tips???

        • Re: Bluesocket Guest access redirection not working
          adt765 New Member

          I am using V2.1.0.14 of vWLAN. The redirect IP address of is correct. This is a private IP range assigned to each AP & is used to give temporary dhcp leases to clients while in the Unregistered Role. It is called NAC addressing and can be found under Provision - Wireless - NAC Addressing.


          When I initially setup captive portal authentication I too had an issue with the IE redirect. What was happening in my case was Internet Explorer was failing an online check for publisher & server certificate revocation. The client was requesting an internet page from a NAC address & the ap NAT'S that to the ap's native vlan ip address. My problem was the ap's native ip address did not have access to the internet, only on campus access. After changing a firewall rule allowing the ap's native vlan ip address internet access Internet Explorer successfully redirected.


          Hope this helps.

            • Re: Bluesocket Guest access redirection not working
              leighton New Member


              Thanks for the reply. I have double checked and the AP I am testing with is in the native Vlan which is the same vlan as all other PC's and have internet access. I double checked the DHCP binding and can see that it is getting an address from the data VLAN.


              I am using 2_2_1_20 if that makes any difference and the controller is in our data centre behind NAT.



            • Re: Bluesocket Guest access redirection not working
              leighton New Member

              Issue got cleared up by support very promptly.

              Point to note. There are a few patches for release 2_2_1_20 that resolve the web server issues for AP's that are connecting across a WAN.


              Problem solved!!



                • Re: Bluesocket Guest access redirection not working
                  nick Employee

                  I went ahead and flagged this post as “Assumed Answered.” If any of the responses on this thread assisted you, please mark them as either Correct or Helpful answers with the applicable buttons. This will make them visible and help other members of the community find solutions more easily as well as award points to the users that helped you. If you still need assistance, I would be more than happy to continue working with you on this - just let me know in a reply.